To view this page ensure that Adobe Flash Player version 10.0.0 or greater is installed.

Flash installation
In order to use the GlobeSpotter manual, Adobe Flash Player version 10.0.22.18 or higher is required. The player can be installed from the Adobe website. On the website you can find the installation instructions, but for your convenience they have also been listed below:

Flash player installation instructions

For support please contact:
support@cyclomedia.nl